You can't connect to the file share because it is not secure. this share requires the obsolete SMB1 protocol.


Today when I was going to access a server file from my laptop, I got the following error.

"You can't connect to the file share because it's not secure. This share requires the obsolete SMB1 protocol , which is unsafe and could expose your system to attack.
Your system require SMB2 or higher."

smb1


Seeing this error, one thing was understood that, this error is coming due to SMB. Now either the SMB protocol has to be upgraded or downgraded.

Here I would like to tell you that my laptop has Windows 10 installed while my server still has Server 2003 installed.

Now Server 2003 supports SMB 1 protocol but it is not installed by default in Windows 10. Which we have to install.

What is SMB Protocol ?

The full form of SMB Protocol is Server Message Block Protocol. This protocol helps in file sharing, data sharing, printer sharing between the server and the client computer.

If data sharing is to be done between a server and client pc, then it is necessary to have the same SMB in both.

Solution :-

In Client PC -
  • Open Control Panel & then program & features.
  • Select Turn Windows features on or off
  • Select SMB 1.0 CIFS File Sharing Support & check  ✔ on same. (mean you have to install it)
  • After installing SMB 1, restart your laptop .
SMB 1

Program & features

SMB 1



Thanks,

Post a Comment

Previous Post Next Post

INNER POST ADS